Home > GPO, Microsoft > Internet Explorer 10.0 doesn’t get Proxy settings from Preferencies

Internet Explorer 10.0 doesn’t get Proxy settings from Preferencies

I had weird problem today. Customer called that GPO I have created to set Proxy server for Internet Explorer doesn’t work anymore on Windows 7. He was right. There was Internet Explorer 10 installed on Windows 7. Proxy configuration was made by Internet Explorer Maintenance:

This was not applied on Windows 7 Internet Explore 10, even there was eventlog it should be applied. Then I set these settings using GPO Preferences. I could create settings just for IE 5,6,7 and 8:

I have decided to create settings using Internet Explorer 8. I set all settings I wanted and saved GPO:

Nothing happened. It’s because this settings are limited to Internet Explorer 8.0. So we need to dig into XML file which handles these settings. XML file InternetSettings.xml is located at \DOMAINSYSVOLDOMAINPolicies{76C1E5D1-9CA6-4682-AD41-FD038DDED1E9}UserPreferencesInternetSettings. When you open this file you can see XML file with all settings. There is one attribute called MAX which defines on which version these settings are applied. I changed it to value “10.50.0.0″ and now everything works:

What a stupid work around :-)

  1. Michal_F
    October 20th, 2013 at 18:56 | #1

    Mna by zaujmalo ci by nepomohola instalcia IE 10 ADMX …

    Administrative Templates for Windows Internet Explorer 10
    http://www.microsoft.com/en-us/download/details.aspx?id=37009

  2. October 21st, 2013 at 11:37 | #2

    Nepomohlo. Pod Preferences stale nevidno Internet Explorer 10, len do verzie 8.

  3. Michal_F
    October 23rd, 2013 at 10:21 | #3

    Mas pravdu, skusal som to dnes v labe (DC 2008R2) a nic.
    Ale z vlasnej skusenosti plati, pouzivat GPO cim menej, co sa tyka proxy a mobility, je asi najlepsie nastavovat proxy pomocou DHCP aj ked to zavisi od viacerych faktorov a prostredia:)

  4. Michal_F
    October 25th, 2013 at 09:53 | #4

    Ak GPO editujem na DC 2008R2 je tam iba moznost IE 5/6/8, problem bude ze tato editacia politik sa vyuziva Internet Explorer Tools GUI, ale ked editujem politiku na Windows 8 pomocou RSAT tak tam mam moznosti IE5/6/8-9/10 (aspon takto som to pochopil, instalacia IE10 na DC ani central store nepomohol).

    By using Internet Settings under Group Policy Preferences, you can configure Internet Explorer globally using the same Internet Explorer Tools GUI that is on an individual machine. When creating a new preference, you will have the option of configuring: IE 5/6, IE 7, IE 8/9, and IE 10. If you don’t have the IE 10 option, make sure you are using the latest RSAT tools (and a Central Store).

    http://deployhappiness.com/internet-explorer-maintenance-replacements/

  5. October 26th, 2013 at 10:43 | #5

    @Michal_F
    Lenze nove RSAT nenainstalujes na stary OS :) Takze treba upgrade DC alebo managovat to z nejakeho novsieho OS.

  6. Michal_F
    October 29th, 2013 at 07:50 | #6

    @Ondrej Žilinec

    Mas pravdu je to postavene trochu na hlavu :(

  1. July 30th, 2014 at 21:34 | #1